Moodle 3.7 or later requires at least PHP 7.1.0 (currently using version 7.0.33-0ubuntu0.16.04.15). Some servers may have multiple PHP versions installed, are you using the correct executable?